cmatrixprobe

发呆业务爱好者

Linux环境下Vue CLI多版本共存

准备工作

1.安装Node.js 8.9 或更高版本 (推荐 8.11.0+),可以直接在官网安装LTS版本

2.如果已经全局安装了vue-cli,通过npm uninstall vue-cli -g卸载

安装不同版本

1.分别创建文件夹

mkdir vue-cli2
mkdir vue-cli4

2.本地安装

如果下载速度太慢可以考虑用cnpm

cd vue-cli2
//安装旧版本的vue-cli
npm install vue-cli
cd vue-cli4
//安装最新版本的vue-cli
npm install @vue/cli

也可以通过

npm install vue-cli@4.1.1

安装指定版本

3.验证版本

cd node_modules/.bin
vue -V
2.9.6
cd node_modules/.bin
vue -V
@vue/cli 4.2.2

4.修改命令

mv vue vue2
mv vue vue4

分别修改为vue2和vue4
同理,将旧版本.bin文件夹下vue-init和vue-list中vue都修改为vue2

配置环境变量

sudo vi /etc/profile

添加

export VUECLI2=$HOME/vue-cli2/node_modules/.bin
export VUECLI4=$HOME/vue-cli4/node_modules/.bin
export PATH=$PATH:$VUECLI2
export PATH=$PATH:$VUECLI4

最后source一下,永久生效重启

source /etc/profile

然后就可以通过vue2vue4分别调用两个版本的vue-cli了

解决git clone速度慢问题

上一篇

Go+Vue | vscode扩展和配置

下一篇
评论
头像 发表评论 说点什么
还没有评论
1084
0